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Session Abstract 

Learn how to get started creating your own engaging animated 
content with Animate CC. In this hands-on lab, we’ll work with a 
variety of project types to design and produce animated banners, 
sweeping scenic animations, and even unique character animations. 
Let’s explore these creative possibilities and more with Animate CC. 

Joseph Labrecque, creative developer and interactive designer, will 
show you how to: 

• Effectively utilize elements of the Animate CC interface through 
creative tools and focused panels 

• Make use of the rich capabilities of Animate to design an 
assortment of vector assets, reusable symbols, and custom 
animations 

• Take advantage of time-tested tips and techniques that let you 
work fast and produce compelling content for your projects 

• Produce a variety of animation types for assorted publishing 
platforms: HTML5 Canvas, HD video, and more 

• Push the creative envelope using the latest exciting features in 
Animate CC 
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About the Instructor 

 
JOSEPH LABRECQUE 

Creative Developer / Interactive Designer / Author, Artist, Absintheur 

Joseph Labrecque is a creative developer, designer, and educator with over 
15 years of experience building expressive web, desktop, and mobile 
solutions. He is presently employed as Senior Interactive Software 
Engineer with Academic Technologies Consulting at the University of 
Denver. Over the past decade, Joseph has authored a number of books, 
articles, and video course publications on design and development 
technologies, tools, and concepts through publishers such as Lynda.com, 
LinkedIn Learning, Peachpit, Pluralsight, and Adobe. He is also the 
founder of Fractured Vision Media, LLC; a digital media production 
studio and distribution vehicle for a variety of creative works. Joseph is an 
Adobe Education Leader, Adobe Community Professional, and a 
member of Adobe Partners by Design. 
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Adobe Animate CC  

A NEW AGE FOR ANIMATION.  

ANY PLATFORM. ANY DEVICE. ANY STYLE. 

 

Design interactive vector animations for games, apps, and 
the web. Bring cartoons and banner ads to life. And add 
action to tutorials and infographics. With Animate CC, 
you can quickly publish to multiple platforms and reach 

viewers on desktop, mobile, and TV. 
 

The industry’s leading animation toolset lets you create apps, ads, and 
amazing multimedia content that moves across any screen.   
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Getting Acquainted with 
the Workspace 

The first thing we will do is get a good look at the various tools and 
panels available to us within Animate.  

Some of these may be familiar for those who have worked with Animate 
in the past, or even other creative tools like Photoshop or Illustrator. 
Other tools may be brand new – such as the new Asset Warp tool  

The Fundamentals  

With any project in Animate CC, the first thing we have to do is make 
some decisions around which platform we want to target, create a new 
document targeting that platform, and then configure certain aspects of 
the project before saving the document. 

Choosing a Document Type 

When creating a new document in Animate, you have a number of 
choices – but every type will take the form of an .FLA file unless it is 
strictly code-based. Any document can also be created as an .XFL 
document – which is a good choice if you’ll be using a version control 
system as it is basically an uncompressed .FLA file.  

Targeting Flash Player?  FLA.  

Targeting HTML5 Canvas?  FLA.  



Adobe MAX 2018 - L246 Creating Multiplatform Animations with Animate CC - Labrecque - 9 

Targeting Virtual Reality?  FLA.  

Targeting raw Video?  FLA. 

Targeting WebGL-glTF?  FLA. 

Targeting Windows, macOS, iOS, or Android? 

FLA.  FLA.  FLA. 

Why is this important? Because you are able to copy assets and 
animations across all of these different publish targets – since they all use 
the exact same authoring file type! 

What determines whether you create a document targeting HTML5 
Canvas, Flash Player, or some other platform is going to depend upon 
your inevitable output needs. For instance… if you are going to be 
generating content for After Effects or straight to video – targeting 
Flash Player makes a lot of sense because you can use all of the creative 
tooling available to you within Animate. However, if you are creating an 
interactive project for distribution over the Web – then HTML5 Canvas 
or any related document type would be the more likely choice.   
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SEQUENCE I:  
Multiplatform Animation 

Creating and Managing Documents 

We'll now look at the basics of the Animate CC application itself – and 
some basic information about managing Animate documents. 

The Animate Start Screen 
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The start screen allows easy access to a number of intents, specific 
document types, and your recently opened files. You'll also find a place 
to access video content showing you some basics and newer features of 
Animate.  

Document Properties and Advanced Settings 

  

This Properties panel will reflect properties of the current document, so 
long as nothing else is selected on the Stage or within the Timeline. 
This includes the Stage width and height, Publish properties, Frames 
per Second (FPS), and Stage background color.  

You can also access Advanced (Document) Settings from this panel. 
From here, you can toggle Advanced Layers on or off. Advanced Layers 
allow for things like layer effects, layer depth, Layer parenting, and 
more! 
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Stage and Pasteboard 

 

The Stage is the area which defines visible content when publishing our 
project. We will likely want to customize the Stage size and background 
color. We do so through the use of the Properties panel.  

The Pasteboard is the area surrounding the Stage. This can be used to 
set content to be hidden off-stage and then either appear or animate into 
view. You can also use this area to place assets you aren’t quite sure what 
to do with them yet. 

Frames Per Second 
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Animate has a frame-based timeline. This means that the overall time it 
actually takes to perform an animation will be based off of the number of 
frames along with the framerate – or frames per second – property of the 
document. 

 
For example, if we have the FPS set to 30 and our total frames in the 
Timeline is 90, then our resulting animation length will be 3 seconds. 
Animate now has a display of seconds along the top of the Timeline to 
help in knowing how long an animation is. In the example above, 1 
second will span 30 frames since the FPS is set to 30.  

It used to be rather difficult to adjust your FPS after you begin 
animating within a document, as the frame spans would not adjust, and 
the entire animation timing would be thrown off. We have an option 
when adjusting FPS which is an optional checkbox titled “Scale frame 
spans”. If this is selected before adjusting a document’s FPS value, 
Animate will adjust the frame spans accordingly. 

Timeline and Layers 
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Generally, you’ll always want to have any asset you are animating on its 
own layer. Even with objects which are not being animated – they often 
benefit from the organizational structures and labeling provided by a 
well-organized timeline. 

Saving Documents 

 

When saving documents, you can save as an Animate Document (FLA) 
or as an uncompressed version (XFL). Generally, you will want to save 
your documents as FLA format as this is the most portable. XFL is best 
if you want to more easily manipulate files and assets or use a version 
control system – but they are much more difficult to deal with otherwise. 

Testing Documents 

 



Adobe MAX 2018 - L246 Creating Multiplatform Animations with Animate CC - Labrecque - 15 

As you work through your animation, you'll be able to test through 
playback controls above the Timeline, but certain aspects will not be 
true-to-life such as MovieClip symbol playback. To really, truly test your 
project… use Control > Test. This will open your project in either the 
integrated SWF player, or in the native web browser, depending upon 
the document type. 

The Basics of Animation  

Now that we are more familiar with the way the Animate interface is 
organized and the procedures for creating and saving documents, it's 
time to begin working on a project.  

1. First, go ahead and create a new document from the start screen. 
Within the Social intent, choose Standard 640 x 480. Animate will 
create a new ActionScript 3.0 project. 

 

2. Look to the Properties panel to confirm the width and height of 
your document.  

3. Change the FPS value to 30. 

4. Save your document. 
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Importing External Assets 

You can import all sorts of assets into Animate: sound files, bitmap 
images, even full Photoshop and Illustrator documents. For this project, 
we'll import a simple PNG file. 

 

I found a nice nighttime sky image through Adobe Spark 
(https://spark.adobe.com/). Spark is a great way to gather free-use 
images from a number of places around the Web for use in a Spark 
project… but you can always figure out the direct URL for the image as 
well and use it in an Animate project!  

5. In your Animate document, choose File > Import… > Import to 
Stage and locate the file Background_Image.png. Be sure and 
choose "All Openable Formats" from the dropdown if you don't 
see it!  
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You'll see that an instance the image is placed upon the Stage and 
if you look within the project Library, you'll also see the image 
itself exists within the Library.  

 
6. Double-click the layer named "Layer_1" and type in the name 

"Background". It's always important to organize your timeline.  

7. Lock this layer by clicking the dot beneath the lock icon and save 
your project. 

Creating Vector Shapes  

We'll now create a basic vector shape over the image that will serve as a 
background element to some text.  

1. Create a new layer and rename it to "Shape". 
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2. Use the Rectangle Tool to create a 76% opaque black rectangle 
along the top, covering nearly 1/3 of the Stage.  

 

Creating Text Objects  

It's time to get creative with text! We'll add a short, concise text element 
which overlays the shape just established. 

1. Create a new layer and rename it to "Message". 

2. Use the Text Tool to create a static text element with the message 
of your choosing. I've created the message "a tree, alone... against 
the world." using the font family "Futura" at 63pt type with the 
color sampled from the background image itself at 100% alpha. 

3. Be sure and position the text over the vector shape in a suitable 
way with the Selection and Free Transform Tools. 
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Tweening Basics  

As the name suggests, Shape Tweens are only usable upon vector shape 
objects within Animate. They can be used to tween one shape into 
another, move shapes around, change shape color across time, or even 
modify a gradient transform in an animated fashion. Shape tweens are 
used when dealing with shapes and drawing objects. 

We'll now employ a shape tween in order to reposition our vector shape 
across the Stage.  
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1. First, extend the frame span of all layers to the 3 second mark. Use 
F5 as a shortcut. 

 

2. Now, select the vector object on the Shape layer at frame 1 and 
look to the Properties panel.  

3. Using the Fill Color selection, take the alpha down to 0%. 

 

4. Now, insert a new keyframe at the 1 second mark, and the 2 
second mark.  

5. At the 2 second mark, select the vector object on the stage and 
using the Fill Color selection in the Properties panel, take the 
alpha back to 76%. 

6. Right-click between the 1 second and 2 second marks in the Shape 
layer and choose Create Shape Tween. The frame span will 
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become filled with orange, indicating a Shape Tween exists 
between the two keyframes. 

 

Converting Assets to Symbols 

Symbols are re-usable, modular assets in an Animate document that 
exist within the project Library. Instances of these symbols are used 
upon the project Stage. Their internal timeline runs in sync with the 
main timeline, so it’s easy to pop them onto the Stage and visualize your 
animation by simply scrubbing the playhead. 

When dealing with symbol instances, you’ll need to employ either 
Classic tweens or Motion Tweens.  

1. Select the text object on the "Message" layer. 

2. Choose Modify > Convert to Symbol with the text object selected. 

3. Choose to create a new MovieClip symbol and give it the name of 
"MessageText". 
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4. Once you hit OK, the text is nested within a MovieClip symbol 
and placed within the Library panel. An instance of this symbol is 
placed upon the Stage and is ready to be animated. 

 

Classic Tweens 

Now that you have a symbol instance on the Stage, you will be able to 
easily animate it using a Classic Tween or Motion Tween. We will use a 
Classic Tween in this case. 

1. Select frame 80 on the Message layer and insert a new keyframe 
(F6). The keyframe at frame 1 is duplicated.  

 
2. Select the keyframe at frame 1. It will be highlighted. 

3. Hover over the keyframe at frame 1 until the cursor indicates the 
keyframe can be moved by changing to appear as a little outlined 
box. Click and drag the keyframe over to the right and release it at 
frame 50. 
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4. Now select the text MovieClip instance on the Stage at the first 
keyframe on frame 50 and look to the Properties panel.  

 
5. Within the Color Effect section, change the Style to Alpha and 

pull the slider down until the value is 0. This will create a 
completely transparent instance. 

 

6. Finally, right-click anywhere between the two keyframes and 
choose Create Classic Tween from the menu. A Classic Tween is 
indicated by violet colored frames. You now have the text fade in 
along with – but not exactly at the same time as – the shape. 
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If you like, you can also adjust other properties of objects that exist in 
either layer. These properties could include x and y position, 
transformations, or even color shifts. 

Easing Presets  

Animate CC now includes Ease Presets for both Shape tweens and 
Classic tweens. When using Classic tweens, you have the additional 
option of setting ease presets and custom eases for each individual 
property to be tweened. 
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Just choose Each property separately from the Easing dropdown. Again, 
this is only possible with Classic tweens and not Shape tweens.  

 

Go ahead and apply some easing to your tweens and see how the timing 
and ease of each is affected by your choices. 

Advanced Animation Techniques 

We'll now move beyond animating single objects and have a look at 
animations that are more advanced and apply to entire frames, layers, 
and the entire document. 



Adobe MAX 2018 - L246 Creating Multiplatform Animations with Animate CC - Labrecque - 26 

Enabling the Camera  

The Camera functionality present within Animate CC allows animators 
to simulate the use of a real-life camera. Previously, animators relied on 
third party extensions of varying quality and compatibility or modified 
their animations to mimic a camera’s movement.  

Animators can use the following camera features that are integral to any 
motion film for efficient storytelling:  

§ Panning with the subject of the frame  

§ Zooming in the object of interest for dramatic effect  

§ Zooming out of a frame to remind the viewer of a larger picture  

§ Modify the focal point to shift the attention between subjects  

§ Rotating the camera view  

§ Apply color effects and tint to an entire scene  

§ Attach layers to the Camera  

§ Create expressive parallax effects with Layer Depth 

The first thing to do when employing the Camera tool is to choose it 
from the Tools panel.  

Click the icon that looks like a camera. This enables the Camera for the 
document, displaying a special Camera layer within the Timeline, 
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Camera overlays on the stage, and Camera Properties.  

 

Note that you can also toggle the Camera on and off with the Camera 
icon at the bottom of the timeline. 

When you set a camera view for your composition, you look at the layers 
as though you were looking through that camera. The camera layer 
behaves like a regular object; you can add tweens or keyframes… and 
animate it like other objects in the document. 

With the Camera enabled for our document, we can now create some 
animated camera movements across the entire Stage. 

Tweening the Camera  

You animate the Virtual Camera in much the same way as you would 
animate a MovieClip or Graphic symbol instance – that is… you can 
either set keyframes at various frames and employ Classic tweens… or 
you can use a Motion tween.  
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A Motion tween is probably the easiest tween type to use of the primary 
tween types that exist in Animate CC since there is no need to expressly 
insert keyframes across the Timeline.  

1. To create a Motion tween for the Camera, select any frame within 
the Camera layer and choose Insert > Motion Tween from the 
application menu.  

We will zoom the Camera back from frame 10 to frame 50.  

2. Select frame 50 first and right-click to bring up the menu.  

3. Choose Insert Keyframe > All to duplicate the Camera's current 
properties.  

4. Now select frame 10 of the Camera layer and with the Camera 
Tool selected… use the Camera UI overlay or the Properties panel 
to zoom the Camera to somewhere between 150% and 155%. 

 

5. Select frame 1 of the Camera layer and duplicate the Zoom value 
for that frame as well. This will create an initial pause from frame 1 
to frame 10.  

Go ahead and play back the animation to see how the Camera and other 
tweens all work together. 
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Applying Frame Effects 

If your document has Advanced Layers turned on (it is on by default for 
documents created in this version of Animate), you will be able to add 
Color Effects and Filters to entire frames and not only individual symbol 
instances on the Stage.  

 
To access Frame Effects after ensuring Advanced Layers are on, simply 
select a frame and look to the Properties panel.  

1. Select any frame on the Background layer. Note that there is no 
need to unlock the layer. 

2. In the Properties panel, you will see a section for Color Effect and 
a section for Filters. 

3. Go ahead and play with the property values in either section.  

Using Frame Effects, you can apply these effects to multiple objects at 
once, within a single layer. The objects within the layer can be of any 
type and do not need to be symbols. The contents of the Background 
layer, for example, is just a bitmap image… which normally cannot have 
any such effects applied to it. The layer itself takes on the properties of a 
symbol with Advanced Layers activated. 
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Note that you can even apply such effects within MovieClip and 
Graphic symbols!  

Using Layer Depth  

Once again, if your document has Advanced Layers turned on it will 
also enable the ability to specify z-depth for each layer (and even folders) 
via the Layer Depth panel. You can access this panel from above the 
timeline or from the application menu under Window > Layer Depth. 
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This presents a major new set of capabilities within Animate CC. It 
allows you to specify how near or far any specific layer is in front of or 
behind the Camera. In addition, Layer Depth is completely tweenable - 
allowing objects to move across layers as an animation progresses.  

Using Layer Depth along with the Camera allows for some really neat 
effects in your animations that you would have had to create in a much 
more manual way previous to this release. This allows the creation of 
depth and parallax effects easily by simply using the Camera against 
layers of varying depth. 

If you like, go ahead and play around with Layer Depth by adjusting the 
z-depth values of various layers.  
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Publishing Your Animation 

Adobe Flash Player 

Animate CC has deep roots in ActionScript and 
the Adobe Flash Runtimes: Flash Player and AIR. 
This should come as no surprise… for the majority 
of its lifetime – this was really the only supported 
platform!  

As a result, choosing any of the AS3-based 
document types allows for the fullest set of creative tooling and the use 
of a deeply mature programming language – ActionScript 3.0.  

A great example from this workshop project is the Camera. Using the 
Camera in an ActionScript 3.0 document gives you access to Tints and 
Color Effects! 

SWF Archive 

You can also publish all of your layers as separate SWF files to be 
imported and further composited in an application like After Effects. 
For this, you can bundle everything within a SWF Archive from Publish 
Settings. 

Note that you can also drag a full FLA document into After Effects with 
this new release as well!  

Projectors 

Sometimes, it’s really useful to have a standalone playback for your Flash 
Player content. A projector is a small application which is basically your 
SWF content that is bundled with a standalone version of Flash Player 
for Windows or macOS.  
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Adobe AIR for Desktop and Mobile 

While we are not targeting AIR in this project, it 
is so closely related to Flash Player that we need 
to make mention of it. AIR is hugely popular for 
building real apps across both desktop and mobile 
targeting Windows, macOS, Linux, iOS, and 
Android.  

While targeting Flash Player, Video, 
Canvas, or WebGL… we could just 
convert the document and just tweak 
things here or there… creating a native 
mobile app is a bit of a different story.  

We’ll probably want to rearrange the 
various elements on the Stage to 
accommodate the device resolution, as 
mobile apps are generally full screen 
experiences. Additionally, we’d most 
likely want to create a true app 
experience around such content, not have a simple 
animation be the entire app.  

Regardless – Adobe AIR is a great target for desktop and 
mobile app development that you can consider when working in 
Animate CC! 
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Exporting your Animation 

When you are happy with the state of your animated project, you’ll want 
to get it out of Animate CC and into some format which a user can 
either view or interact with.   

There are two main ways of doing this – exporting and publishing. As 
an example of the differences here… you can export an animated GIF 
from basically any document type you choose – ActionScript 3.0, 
HTML5 Canvas, WebGL… the document type doesn’t really matter 
much. However, if you want to publish to Flash Player then you must do 
so from an ActionScript 3.0 document type. If you want to publish an 
interactive for the native web – you’ll likely choose HTML5 Canvas as 
your document type.  

Video and Adobe Media Encoder 

If we render our project to a web-friendly video 
format like MP4 – we don’t have to worry about the 
limitations of certain platforms. Just make an 
awesome little video!  

One of the major uses of Animate is to design and 
produce content for television and video… so we are good! The fact that 
an ActionScript 3.0 based document type is generally the best choice for 
video simply due to the number of extra tools and filters that are 
available should not be overlooked. 

Choose File > Export > Export Video and then make some decisions 
around where to export the video and at what resolution. Animate does 
a frame by frame rendering of the content… so what ends up in the 
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video is precisely what was authored. It even takes into account dynamic 
animation through the use of code! 

Once the video is rendered, we can fire up Adobe Media Encoder to 
render it to any format desired. You can also just import the video to an 
Adobe Premiere Pro or After Effects project. 

Animated GIF and other Image Formats 

Select File > Export > Export Animated GIF and a 
dialog will appear. You can apply individual preset, 
image, size, color, and animation settings to the 
optimized and 2-UP views and use the various 
preset options to set various parameters.  

• Select Matte to modify and blend the 
background color across the edges of the asset.  

• Select Transparent or non-transparent to work with the color 
picker and the transparent option to control the transparency of 
the asset. 

• Set the Image size, color and animation options.  

The file size values are displayed below the screen and clicking the 
Preview button allows you to preview the animation and navigate to a 
specific frame. Additionally, you may choose Select Clip to Stage in the 
image size panel to set the clipping boundary to the stage.  

When ready, select Save to save the animated GIF! 
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When you save an optimized file using the Export Animated GIF 
option, you can generate an HTML file for the image. This file contains 
all the necessary information to display your image in a web browser.  

Converting between Document Types  

When considering target platforms… perhaps you made a mistake in 
your initial evaluation – or the request comes in for another platform. 
Not to worry. By selecting File > Convert to… from the application 
menu, you can easily repurpose animations and assets for additional 
target platforms. For instance, maybe we want to convert our project to 
HTML5 Canvas for native web browser playback.  

HTML5 Canvas 

Content created in Animate can now to be 
published directly to a number of modern 
HTML5 formats. The primary document type 
which allows this publish target is HTML5 
Canvas.  

When creating content using this publish target, Animate will leverage 
the CreateJS JavaScript libraries to output an entire animation or 
interactive project for the HTML5 canvas element. You can even write 
JavaScript in the Actions panel!  

Publish Settings can be easily accessed from the Properties panel and 
include a LOT of different options. You can actually perform a true 
publish through the File > Publish option in the application menu. 
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SEQUENCE II:  
Feature-Focused 

Animations 

Layer Parenting 

Layer Parenting is a new feature that allows the construction of 
hierarchical layers. You create parent-child relationships between layers 
to allow transformations of parent layers to additionally be applied to 
their children. We'll be building a skeleton that can be manipulated and 
even animated based upon these concepts. 

Open the provided Skeleton.fla Animate file. 

Assemble your Skeleton 

We'll start out with a set of skeletal bones and assemble them as a 
complete skeleton on the Stage. Look to the Stage to find the various 
bones associated with our skeleton.  
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Assemble your skeleton and tweak the transform points using the Free 
Transform tool when necessary. 

 

Note that each bone is on its own layer!  

Enable Layer Parenting 

In order to use layer parenting, we need to have each of these instances 
on their own layer. This has already been done for you.  

 

Enable layer parenting by switching layer parenting on from within the 
timeline. You now have a new layer parenting view exposed that can be 
manipulated.  
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Layer parenting can only be used when the document has Advanced 
Layers toggled on.  

Building a Rig 

You may want to reorder your layers so that the intended hierarchy is 
apparent – but it isn't entirely necessary. Use the little parenting anchors 
to establish a relationship among all bones.  

 

I suggest making the ribcage the root parent layer with the skull, upper 
arms, and pelvis connected as direct children. Then, work your way 
through the further extremities until the entire skeleton is rigged. 

Adjust your Transform Points 

The placement of transform points is important for this sort of work as 
they determine how scaling and rotation function.  
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Turn snapping off completely and then use the Free Transform tool to 
adjust the white, circular transform point of each bone to a natural point 
of rotation.  

Animate the Skeleton 

You can now reposition and rescale the entire skeleton by selecting the 
ribcage. Finds a suitable spot to place the skeleton and resize 
appropriately. You can also manipulate the position and rotation of child 
bones to really customize the initial posture. 
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With this done, think of how you'd like to animate the skeleton. Maybe 
all it will do is simply reach to the sky and shift its body slightly. Maybe 
the skeleton will wave its arms wildly. In any case, I suggest using 
Motion Tweens. 

 
Create a motion tween on those layers that will be animated and make 
adjustments along the timeline to create motion tweened animation. 

Asset Warping 

Use the new Asset Warp tool to establish a mesh over a shape or bitmap 
image and then use the contextual overlay to modify how the mesh and 
asset work together visually. 
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Getting Started 

Create a new HTML5 Canvas document type from the Advanced area 
of the Start Screen. 

 

Now open the CC Libraries panel and do a search for an image that you 
can have fun with. I did a search for the term "pirate".  

 
Once you locate something good from Stock, drag an instance onto the 
Stage and resize it appropriately. Note that this is only a preview of the 
asset from Adobe Stock – but it works for our purposes.  
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Warped Assets can be created on shapes or bitmap images – so this 
preview from Stock will be just fine. 

Using the Asset Warp Tool 

Select the new Asset Warp tool  from the Tools panel. 

Place a handful of pins at strategic points across the image. A mesh is 
automatically created based upon the points set. This is a warp mesh and 
determines how the image is distorted as pins are moved from their 
original location. 
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I've placed pins at prominent features like the brow between his eyes, the 
corners of his eyebrows, the nose, cheeks, chin, and so on.  

Animating a Warped Asset 

You can use the Asset Warp tool to move currently placed pins or to 
rotate existing pins. Both of these actions will distort the mesh and its 
Warped Asset visually. We can tween these mesh distortions across 
keyframes.  

Before you do anything - duplicate the keyframe down a second or two 
past frame 1. With the keyframe (and the mesh with full pin set) 
duplicated, you can warp the mesh on the secondary keyframe with the 
Asset Warp tool, leaving the original intact.  

Once you are satisfied, create a Classic Tween between the two 
keyframes and preview your animation. The mesh will tween between 
the two keyframes.  
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You may also want to place some extra frames at the end of your 
animation as I've done. 

Automated Lip-Sync 

Animate can now automatically assign specific frames of a Graphic 
symbol to an instance of that symbol across the timeline, using imported 
audio files to determine which frames to apply at which locations along 
the timeline. 

Open the provided Moon.fla Animate file. 

Moon  

The animation features a number of layers and a moonrise. At one point 
in the animation, along the audio layer, you will find a blank keyframe. 
This is set just after the moon rises and stops in the sky and is where we 
will place our audio for playback. 
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You'll also note that this is an ActionScript 3.0 project. The primary 
reason for this is that in order to use the lip-sync feature, we must have 
audio on the timeline and set to stream. The audio stream choice binds 
audio playback to specific frames and simply does not exist in other 
documents types.  

Audio File Integration 

You will find an audio folder within the provided files on your machine. 
Within this folder are a set of interesting recordings – Edgar Allen Poe 
quotes as read by my daughters. You can choose between any of these 
recordings to pull into your project library.  

Just choose File > Import > Import to Library and choose one of the 
available MP3 files. With that done, you'll assign the sound to a frame 
in the audio layer. Choose the blank keyframe at frame 90 of the audio 
layer and look to the Properties panel. 
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You will see the properties for this specific frame. Under the Sound 
section, choose an audio file from the Library using the Name dropdown 
selector.  

Be sure and change the Sync selection to Stream before moving on! 

 

With that done, you will have an audio waveform appear at frame 90 of 
your audio layer. Since the sync is set to stream, scrubbing the playhead 
will result in a frame by frame audio preview.  

Explore the Viseme Graphic Symbol 

Automatic lip sync in Animate works by mapping certain standard 
speech sounds to a set of mouth frames within a Graphic symbol. Go 
ahead and have a look within the Mouth Graphic symbol and you will 
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see a different mouth shape for each sound – and note they are all 
labeled in this same way as well for easy identification.  

 

Automatic Lip-Sync 

To use the automatic lip sync feature, select the mouth instance on the 
timeline and look to the Properties panel.  

 

In the looping section, click the button that reads "Lip Syncing…" and a 
Lip Syncing dialog will appear. 
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This dialog allows you to set up your viseme by clicking each speech 
sound and selecting the proper frame which matches that sound from 
your Graphic symbol. Once the viseme has been set up, choose the 
audio layer to sync against and click Done. 

 
Have a look in the Timeline to see that the dialog has inserted 
keyframes at all the appropriate places and has chosen specific frames 
based off the viseme you've established. You can play the animation in 
the Timeline or through the Control > Test menu option. 

Of course, you can modify these frames if you notice any errors but the 
automatic lip syncing does a wonderful job!  
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Exploring Virtual Reality 

Animate CC now includes a new set of Virtual Reality document types 
– both panoramic, and full 360 degrees.  

VR Document Types 

Create a new VR Panorama document from the Start Screen. 

 

Both VR document types work in very similar ways and support the 
inclusion of additional animated assets and interactivity.  

Implementing a Background Texture 

Import Panorama.jpg onto the stage by choosing File > Import > 
Import to Stage… 
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The bitmap will be placed upon your stage and spill well onto the 
pasteboard since it is way, way larger that the stage size. We can fix this 
by going into Document Settings and clicking the Match Contents 
button. 

 
The stage is resized automatically to match the contents upon it. Click 
OK to exit out of Document Settings. 

 

Zooming out to 13% (or Fit in Window) now have a nice, wide 
panoramic shot of a park near my home. You may even be able to see 
Denver from here!  
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The final thing we need to do is to specify the layer with our panoramic 
photograph for Texture Wrapping. Do this by clicking the Texture 
Wrapping icon alongside the Visibility and Lock icons in the Timeline. 

Using the VR View Panel 

You can open the VR View panel at any time while working in Animate 
by choosing Window > VR View from the application menu. 

 
VR View allows you to click and drag to experience the panorama as a 
preview. If you have placed MovieClip symbol instances along the stage, 
you can even adjust their positioning in VR space through this view.  

You can also preview in the web browser by choosing Control > Test. 
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Exploring Further 

Play around with creating additional layers and building animations atop 
your panoramic texture. Note that you should not specify anything that 
will be animated as a background texture as you've done with the 
imported bitmap.  

WebGL glTF and the 3rd Dimension 

WebGL content is actually GPU-accelerated, meaning that it makes 
direct use of the hardware GPU (Graphical Processing Unit) instead of 
sharing rendering tasks with everything else running on the CPU 
(Central Processing Unit). This makes for a much more effective and 
powerful rendering target. We'll have a very brief look at these new 
document types before concluding. 

WebGL Document Types  

Create a new WebGL glTF Extended document.  

 
While WebGL glTF Standard with create a standards-compliant 
output… certain features like transformative skew, filters, and 
interactivity will not function using the standards-based format. This is 
one of the reasons we are using the extended version for this example.  
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Importing 3D Objects  

We'll be having a look at the inclusion of standard WebGL glTF GLB 
files within the stage of our glTF Extended project.  

Choose File > Import > Import to Stage and select the 
2CylinderEngine.glb file from your project files.  

 
A placeholder MovieClip symbol instance appears on the stage. You can 
animate this, move it around, and change its properties like any other 
instance… however, you won't see it rendered until you test or publish. 

Adding Interactivity 

While animation is certainly a valid use for Animate CC, the application 
is great for implementing interactivity as well.  

Open the Actions Panel by choosing Window > Actions from the 
application menu. 

Click the Add Using Wizard button in the upper right and the Actions 
Wizard appears. 
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You can see a set of WebGL glTF Extended specific actions that can be 
chosen – including the import of GLB files through code. Very neat!  

Publishing WebGL glTF Files 

While the Extended version of WebGL glTF will publish with its very 
own runtime from Adobe, publishing the Standard version will create 
standards-compliant files which can be played back in any standard glTF 
viewer.  

Choosing Publish Settings with a Standard document type allows you to 
choose between GLB or GLTF file output. 
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Either one of these can be played back in stardards-based viewers such 
as the one found at https://sandbox.babylonjs.com/ - just drag and drop 
your GLB file into the browser window! 

 

When publishing the Extended version, you will not have the option to 
choose output formats since this is a extended, Animate-specific verion 
of the glTF standard which uses its own custom runtime.  
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In either case, you can browse to file location and name the output, set 
the image resolution, clean up the generated JSON or not, and choose 
from the standard playback options of looping the Timeline and 
whether or not to publish hidden layers.  

Pretty straightforward!  
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Additional Resources 

To keep up on all things Animate, here are a few resources: 

• Adobe Animate Team Blog 
https://blogs.adobe.com/creativecloud/tag/adobe-animate-cc/  

• Adobe AIR and Adobe Flash Player Team Blog 
http://blogs.adobe.com/flashplayer/  

• Adobe Animate CC Learn and Support 
https://helpx.adobe.com/animate.html  

 
To contact Joseph Labrecque, note the following links: 

• Website 
http://josephlabrecque.com/  

• Twitter Profile 
https://twitter.com/JosephLabrecque  

• Blog - In Flagrante Delicto! 
http://inflagrantedelicto.memoryspiral.com/  

• Lynda.com Author Page 
http://www.lynda.com/JosephLabrecque  

• Pluralsight Author Page 
https://www.pluralsight.com/authors/joseph-labrecque  

• Amazon.com Author Profile 
http://amazon.com/author/josephlabrecque  



Adobe MAX 2018 - L246 Creating Multiplatform Animations with Animate CC - Labrecque - 59 

 
 

 

THANK YOU! 
HAVE FUN WITH ADOBE ANIMATE! 


