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Abstract 
Need to get up to speed on the tooling in Flash Professional CC for your client and 
creative work? Maybe you need to target the web, iOS and Android devices, HD 
video and print. Great news: Flash Professional CC has been enhanced to expand 
upon the traditional Flash runtime targets and reach the native web through HTML5 
Canvas and WebGL (and more) to help all types of use cases for desktop, mobile 
and beyond. 

Objectives 
Participants should come away from the lab with the following: 

• A solid idea of how to use Flash Professional in their creative work 

• The ability to create assets within Flash Professional 

• The knowledge to bring in Brushes, Colors, and more with CC Libraries 

• How to work with advanced tools such as the Paint Brush and Bones tool. 

• The Understanding of a variety of target platforms now available 

• A renewed, modern, and positive perception of Flash Professional 
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About the Instructor 
 

 

Joseph Labrecque 
Senior Interactive Software Engineer - Artist - Author – Absintheur 

 Adobe Education Leader - Adobe Community Professional 

Joseph Labrecque is primarily employed by the University of Denver as a senior 
interactive software engineer specializing in the creation of expressive desktop, web, 
and mobile solutions. His work incorporates a strong focus on the Adobe Flash 
Platform alongside more general web standards initiatives involving the use of 
HTML5, CSS, JavaScript, and related technologies. 

He is also the proprietor of Fractured Vision Media, LLC; a digital media production 
company, technical consultancy, and distribution vehicle for a variety of creative 
works. Joseph authors video courses and written works through organizations 
which include Lynda.com, Train Simple, Adobe Press, Peachpit, Packt, O'Reilly, 
Brainbuffet, and video2brain. He speaks regularly at conferences such as Adobe 
MAX, FITC, 360|Flex/Stack, and for a variety of local community groups. 
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Joseph is an Adobe Education Leader and Adobe Community Professional. He 
received the Adobe Education Impact Award in 2010 and currently serves on the AEL 
Advisory Board. He is also an Apache Flex Committer. 

Recent Publications 
If interested in learning more about using Flash Professional CC to create content 
targeting Flash Player, Adobe AIR, HTML5 Canvas, HD Video, WebGL, Apple iOS, and 
Google Android… have a look at the following publications! 

Lynda.com:  HTML5 Canvas and WebGL in Flash Professional CC 

 

Create a shared pool of content for a set of 
related projects—an HTML5 video, a 
WebGL-rendered interactive ad, and an 
HTML5 Canvas game—using Flash 
Professional CC. 

 

Train Simple: Flash Professional CC Mobile App Development 

This course is designed for experienced 
Flash and ActionScript designers and 
developers. Joseph Labrecque will show 
you how to take advantage of mobile 
device hardware using new API's in 
ActionScript 3.0. You'll see how you can 
produce apps and publish them for 
mobile devices. 
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More Publications… 

Can be found at the following addresses: 

Books: http://josephlabrecque.com/books/ 

Videos: http://josephlabrecque.com/books/video.html  

New in Flash Professional CC 2015.1 
This new release of Flash Professional CC is the biggest release in YEARS! There are 
so many new tools and features for drawing, animating, export, workflow, and more. 
A list of most of these features is provided for you here. 
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• New Paint Brush Tool 

• Brush Library filled with vector art brushes 

• Vector Art Brush Editor 

• Tagged Swatches 

• CC Libraries Panel  

• OAM publishing support for AS3, WebGL, and HTML5 Canvas 

• Publish text as outlines in HTML5 Canvas documents 

• Color-coded onion skinning 

• Stage Rotation Tool 
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• SVG Import dialog 

• Proportional Stage Scaling options 

• Stage contents scale proportionally to Stage size 

• Video Export to multiple resolutions 

• Improved drawing experience with Brush tool 

• Improved Object Drawing Mode Representation 

• New buttons for commonly used operations in the Properties Panel 

• Custom Platform optimizations 

Getting Acquainted with the Workspace 
The first thing we will do is get a good look at the various tools and panels available 
to us within Flash Professional. Some of these may be familiar for those who have 
worked with Flash Professional in the past, or even other creative tools like 
Photoshop or Illustrator. Other tools may be brand new – such as the new Paint 
Brush. Major workspace areas are highlighted below. 
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The Flash Professional Workspace 

1: The Stage and surrounding Artboard 
Anything within the Stage is visible within your project. The Artboard is the 
surrounding area, which is off-stage and not normally visible. 

2: The Timeline 
The Flash Professional Timeline is where you manage Layer order and animate 
content across Frames. It is also where the powerful Motion Editor can be accessed.  

3: The Library and Properties Panel  
The Flash Professional Library is where any of your symbols and imported assets are 
stored. Vector shapes which have not been made into Symbols will not appear 
within the Library – only existing on the Stage. 
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4: Creative Cloud Libraries 
The Flash Professional now includes integration with Creative Cloud Libraries! 
Access all of your generated content including shapes, colors, and brushes for use in 
your Flash Professional projects! 

5: The Tools Panel 
This is the spot from where all out our creative tooling can be accessed! Brushes, 
shapes and primitives, the Pen Tool, and more! 

Project 1: Designing Scenic Assets 
The first project will bring us straight into the Flash Professional workspace to create 
a number of scenic assets upon the stage. We will use a number of vector drawing 
tools to design our setting. 

 

Building Scenic Assets 
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Creating a New Project 

The first thing we must do is create a new project in Flash Professional.  

1. Create a new ActionScript 3.0 document 

2. Set the stage to a resolution of 640x360. This is a 16:9 ratio and should be 
great for video or animation.  

3. Set the frames per second (FPS) to 30. 

4. Choose (#000000) black as the background color. 

 

Setting up the Stage 

Something advisable when setting up a new project in Flash Professional is to 
configure the snap settings, rulers, and guides. 

1. The first thing to do is set the snap settings of your project to be as tight or 
forgiving as you require. I find that the stricter settings can really help when 
drawing out assets across the stage. Access via View > Snapping from the 



 

Adobe MAX 2015 | Unleashing the Creative Power of Flash Professional CC   

 

13 

application menu. 

 

2. Additionally, if using guides, you will want to enable rulers via View > Rulers. 

3. Guides themselves can be pulled from the rulers and overlaid across the 
stage. Guides can assist with measurement and visualization. 

Vector Drawing Tools 

We will now use a number of the shape and selection tools available in Flash 
Professional to design a wide-open sky and gently sloping, grassy hill. 

1. Create a layer called “Sky”. 

2. Choose the Rectangle tool. Then click and drag to create a shape the size of 
our stage. If you need to, you can always define an exact size through the 
properties panel. 

3. Use the Color panel to create a custom gradient swatch. Have one step be a 
lighter blue [#4E6CAF] and the second step be noticeably darker [#08131E]. 
Go ahead and lock this layer once you are finished. 

4. Create a layer called “Ground”. 

5. Choose the Rectangle tool once again and draw out a grassy area [#006600] 
from the bottom of the stage to about ¼ the way up. It will be a complete 
rectangle with straight lines, initially. 
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6. Now use the Selection tool and hover over the top of the hill. Be sure the 
shape itself is not selected.  

 
The cursor will transform into a small curved line as you hover over the path – 
click and drag with the cursor in this form to pull the path into the shape of a 
small hill. 

 

Color Management 

You can use the Color and Swatch panels to manage colors within your Flash 
Professional project. With the latest release of Flash Professional, you also have 
access to a CC Libraries panel through which you can grab all the swatches created 
with Adobe Capture. 
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Just click on the CC Libraries panel and CreativeSync will do the rest. This panel 
provides access to shapes and brushes too! 

Variable Width Strokes 

The next think we will do is create a spooky moon. One the coolest new features of 
Flash Professional is the Width Tool and the ability to apply Variable Width Profiles 
upon your strokes. 

1. Create a new layer and give it the name of “Moon”. 

2. Grab the Oval Primitive Tool and draw out a circle. To create a circle, just hold 
down SHIFT as you click and drag.  

3. Make the circle measure around 120 pixels with a fill of #FFFFCC and a stroke 
of #FFFF33. This will become our moon. 

4. Have a look at the Properties Panel and apply a variable width stroke profile 
to the selected circle shape.  
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5. Now grab the Width Tool and use it to adjust the variable width along the 
object stroke. You can add control points and adjust existing points using this 
tool. 

 

Using the Paint Brush Brush Tool 

Flash Professional has had a Pencil Tool for strokes and a Brush Tool for fills for 
quite a long time. They are great for creating free-form shapes, but the new Paint 
Brush Tool is something else altogether. It allows you to draw out paths with rich 
vector art brushes applied along them. We’ll use this new tool to draw out some 
nice grass. 

1. Right above the Moon layer, create a new layer and name it “Grass”. 

2. Select the new Paint Brush Tool from the Tools Panel and click the small 
paint can icon in the Properties Panel to open the Brush Library. 
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3. Double-click on the brush called “Calligraphy 2” which you can find under 
Artistic > Ink. This brush will make it easy to draw out small blades of grass. 

 

4. Double check the bottom area of the Tools Panel to be sure that Object 
Drawing Mode is enabled and begin sketching out blades of grass from the 
area around our hill. 

5. Experiment with different color combinations as you draw out the blades of 
grass. It is effective to make some be the same color as the hill shape – but to 
also deviate from that somewhat, making some lighter or darker. 

6. Move this layer beneath the Ground layer. 

Project 2: Building a Character  
Now that we have created a scene to set up our projects, we will move ahead and 
design a character who will reside in this scene.  
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A Skeletal Creature 

Drawing Character Assets 

The animated character we will create – a BAT! – will be constructed as a MovieClip 
Symbol formed from basic shape assets and animated through the MovieClip 
Timeline. The first thing we will need to actually draw out our assets. 

1. For the head, use the Oval Primitive Tool to draw out a circle of about 120 
pixels around. Use the color #663366 or similar to have a rich violet color as 
the fill and choose to disable the stroke. 

2. Next we will draw the body – again with the Oval Primitive Tool. This time, it 
really should be an oval though! Have it measure about 70 pixels wide and 50 
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pixels high. 

 

3. Once the body is created, choose the Free Transform Tool and shift the 
transform point toward what would be the neck area. Now simply rotate and 
move the shape until aligned with the head. 

 

4. Let’s give the bat some nice leathery wings! We will again use the Oval 
Primitive Tool but with a slight twist. In the Properties Panel, with the tool 
selected, change the Start angle to a value of 123. The object width should be 
105px and the height 70px. This will create an oval with a nice chunk taken 
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out of it we can modify for use as a wing. 

 

5. Now, position the wing at an appropriate point in relation to the rest of the 
body. Darken it, slightly… I’m using the value #603060. 

6. Duplicate the wing object by either a copy/paste command set, or by holding 
down ALT while clicking and dragging the current object.  

7. Darken the new wing to give perspective (as it will appear behind the body). I 
am using a variation of the current color: #532A53. 

8. Use the Free Transform Tool to reverse the new object along the y axis, 
position and rotate just as was done with the original wing so that it appears 
in the proper location to the rest of the body. 

 

9. Now right-click upon the wing and choose Arrange > Send to back – the 
darkest wing should now appear behind all other objects which compose the 
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bat’s body. 

 

Convert to a MovieClip Symbol 

A MovieClip Symbol has a timeline just like that of the main Stage, and is the primary 
symbol for creating custom functionality within Flash Professional. When a symbol 
is created, it resides in the project Library.  
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The symbol acts as a blueprint to instruct Flash Professional on how to construct an 
instance of that symbol. Instances are representations of the symbol within the 
project Stage and Timeline. 

• Select all the objects which make up the bat’s body and choose – Modify > 
Convert to Symbol from the application menu. 

• In the Convert to Symbol dialog which appears, be sure to set the Type to 
MovieClip and give it a name of “Character”. Hit OK to continue. 

 

• There are two ways to edit a MovieClip once it is created. The first is to go to 
the Library and double-click upon the symbol entry found there. The other 
method is to simply double-click into the symbol instance that exists on the 
Stage. Use either method to enter the symbol. 

• You may want to zoom in tight on the head for this next part. It’ll make things 
a lot easier.  

• Create and name a new layer which will hold the eyes. Use whatever tool you 
wish to draw out some eyes for the bat. I’m simply using the Oval Tool with 
separate colors for stroke and fill. 

• Now for the ears… let’s use that awesome new Paint Brush Tool again! 
Choose a raggedy-looking art brush from the Brush Library and draw some 
ears in the same color as the head and body: #663366. I’m using that same 
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calligraphy brush used for the grass, but with a much thicker stroke size. 

 

Building a Skeleton with the Bones Tool 

The Bones Tool has been absent from Flash Professional ever since the application 
was rewritten for 64-bit. Today, however – the Bone Tool, Bind Tool, Armature 
Layers, and everything else in the Flash Professional Inverse Kinematics system is 
back.  

Note that the Bone Tool is sort of overkill for such a simple animation – but we need 
to get the word out… the Bone Tool is back! 

1. We’ll now select all of the body and head parts to create a unified MovieClip 
symbol named “Body”. The reason we do this is that we will be creating an 
armature composed of MovieClip instances. 

2. Additionally, create a MovieClip Symbol for each wing. I’ve named them 
“RWing” and “LWing”. Even with the “Character” MovieClip now composed of 
3 separate sub-MovieClips, everything should still look the same. 

3. Before going through the trouble of building out a series of bones for our 
armature, we’ll want to be sure each Transform Point is properly configured. 
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We’ll position the Transform Point of each wing to the shoulder of our bat 
character to facilitate natural joint movement. Just use the Free Transform 
Tool to click and drag the small white circle. 

 

4. Now select the Bone Tool from the Tools Panel. We’ll use this to define the 
bones within our armature. Note that every internal MovieClip instance within 
our “Character” is all on a single layer. Using the Bone Tool allows multiple 
symbol instances to reside upon a single layer for animation. It is THAT 
special! 

5. Click upon the central body point (think of his heart) and drag a bone out to 
the right wing- then release. A bone will now be visible upon the bat 
character.  

6. Click directly upon the heart once more and drag out to the left wing to create 
a second bone. That’s it! You’ve created an armature through use of the Bone 
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Tool. 

 

7. Now sometimes when you build an armature, the object arrangement may 
not be perfect. Objects which should appear in front of, or behind other 
objects will show up incorrectly. If this happens to you – no big deal. Just 
right-click on the errant object and choose Arrange to move objects forward 
or backward in the stacking order. 

8. We’ll also need to be sure that the Transform Point for each wing is properly 
aligned. If it is not, as you create poses with your armature, the animation 
between poses may become erratic! Use the Free Transform Tool to move the 
Transform Point of each wing instance so that it aligns to the character’s 
shoulders – where you would expect a joint to naturally occur. 

9. One last thing; it may help to constrain the angle of rotation so that the wings 
cannot stretch or rotate too far beyond the motion expected of a bat. To set 
this property, select a bone with your Selection Tool and tweak the angle 
constraints within the Properties Panel. 

Managing Poses 

Once an armature is assembled, it has a default Pose. Any time we create create a 
change in properties on any particular frame – that is called a Pose. Poses can be 
copied for easy modification and reuse. 
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1. To set up our animation, lets extend our frame span out to frame 9. Move the 
playhead to frame 9 in the Timeline and from the application menu, choose 
Insert > Timeline > Frame.  

2. We’ll have an animated sequence of the wings flapping, so let’s just copy the 
current pose, and then modify when needed. Right-click upon frame 1 and 
choose Copy Pose from the menu that appears. 

 

3. Move the playhead to frame 5, right-click, and chose Paste Pose to duplicate 
the exact pose on frame 5.  

4. Next, move the playhead to frame 9 (the last frame), right-click, and choose 
Paste Pose once again to duplicate the pose on frame 9.  

5. Move the playhead back to frame 5 so that we can modify the pose in order to 
create some animation. Since we are using an armature, we don’t even need 
to use the Free Transform Tool to rotate – just use the Selection Tool to grab 
the wing and pull down. Notice how it naturally moves into position? This is 
the power of inverse kinematics! Move both wings down a bit to appear as 
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though the bat is flapping.  

 

6. Scrub the playhead to preview – since we have the exact same pose on the 
first and final frame… this results in a seamless, looping animation. 

Project 3: Animating the Scene 
In this portion of the workshop, we’ll perform the bulk of the animation for both 
scenic assets and the bat character as well. 
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Motion Guides Create Flight 

Working with the Timeline 

We’ll now animate everything that’s been created and laid out upon the Stage in 
previous projects. Let’s employ a variety of tween types and techniques to do so. 

1. The first things we’ll need to do is extend the frames on all layers out to frame 
80. To do this, select frame 80 and choose Insert > Timeline > Frame from the 
application menu. 
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2. Next, position the character instance off Stage on the Pasteboard. We’ll have 
the bat kind of swoop in from off screen so it makes sense to set this up now. 

 

3. Additionally, move the moon asset past the bottom left corner of the Stage 
and well onto the Pasteboard there as well. Our intent is for the moon to rise 
up from behind the hill. 

Animating the Moon  

A Motion Tween is probably the easiest tween type to use of of the 3 (4 counting 
armatures) that Flash Professional provides. The reason I state this is that unlike the 
2 other tween types, there is no need to expressly inset keyframes across the 
Timeline. Just move the playhead around, tweak your properties, and Flash 
Professional does the rest. 

1. In order to use a Motion Tween to animate the moon, we’ll first need to 
convert it from a shape into a MovieClip Symbol instance. To do this, select 
the shape and choose Modify > Convert to Symbol from the application 
menu. In the dialog that appears, provide a symbol name of “Moon” and be 
sure to select MovieClip as the symbol type. 

2. To create a Motion Tween, right-click anywhere upon the Moon layer and 
choose Create Motion Tween. The background of all affected frames will turn 
blue, indicating a Motion Tween has been established. 
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3. Move the playhead to frame 80. Any properties you change of the moon 
instance will be recorded in a keyframe that is generated on this frame. Using 
the Selection Tool, move the moon up to an appropriate place in the sky. Use 
the Free Transform Tool to make the diameter of the moon as it starts out to 
be larger than where it ends up. 

4. Notice how we now have a Motion Guide visible on the Stage between the 
two positions? Using the Selection Tool, we can bend and adjust the curve of 
this guide. Simply hover over the guide until a small arc appears next to the 
cursor and click to pull and push the motion guide. The small dots you see 
represent the position of the moon upon each individual frame represented. 

 

5. One of the neat things about Motion Tweens; since we are working with 
MovieClip Symbol instances, we can tween any of he properties of MovieClip 
Symbol instances, including Color Effects and Filters. Select the moon 
instance on frame 1 and under Color Effects in the Properties Panel, choose 
“Tint” and set the color to #FF9900 and the tint value to 50. Do the same for 
frame 65, but set the tint value to 0. Preview the animation and see how the 
actual tint is tweened with the rest of the animated properties. 
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6. Double-click upon the Moon layer to reveal the Motion Editor. This is a highly 
productive tool which allows you to tweak the various properties being 
tweened and apply some rather interesting easing parameters to them. We’ll 
now apply an ease out to our tween. With the Motion Editor Open, choose 
Simple > Slow from the ease presets directly below the visible easing curves. 
Double-click on the layer frames once again to close the Motion Editor. 

 

7. Be sure that your Moon layer is placed directly above your Sky layer but below 
your Grass layer. 

Animating the Character 

Now we will go ahead and animate our character across the screen using a Motion 
Tween, taking advantage of the Motion Guide features. 

1. Again, create a Motion Tween by right-clicking anywhere upon the Character 
layer and choose Create Motion Tween. 

2. Now, scale down the bat a bit and make sure it is completely off Stage within 
the Pasteboard.  
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3. Select frame 25 and right- click Choosing Insert Keyframe > All. This will 
basically duplicate the current state of the object. 

 

4. Move the playhead to frame 45 or so and adjust certain properties of the 
MovieClip instance such as rotation or scale. Move to the final frame of the 
animation and do the same. Be sure that the instance is larger in scale and at 
an entirely different position on this frame. 

5. Now, use the Selection Tool to modify the motion guide and make the tween 
more natural and interesting. You can do this by modifying the motion guide 
with the Selection Tool. 
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Using Shape Tweens 

As the name suggests, Shape Tweens are only usable upon vector shape objects 
within Flash Professional. They can be used to tween one shape into another, move 
shapes around, change shape color across time, or even modify a gradient 
transform in an animated fashion. 

1. We are going to adjust our Gradient Transform on the “Sky” layer with a 
Shape Tween to make it appear to darken as the moon rises. Insert a new 
keyframe on frame 80, then right-click anywhere along the Sky layer and 
choose Create Shape Tween. 

2. Choose the Gradient Transform Tool (grouped with the Free Transform Tool) 
and select the sky object on frame 80. Do not modify the keyframe properties 
on frame 1 – they are fine. 

 

3. Now, click on the small white circle in the center of the shape. This is your 
gradient center point. Dragging that around with your mouse will shift the 
center of the gradient around. Drag it up a ways, and the sky will darken! 
Since we have a Shape Tween in place – this transition now animates along 
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with the moonrise. 

 

Stopping the Playhead 

If you go ahead and test the project at this point by using Control > Test from the 
application menu, you’ll see how great everything has come together… but the 
animation loops continuously… let’s stop it on the final frame. 

1. The first thing we need to do is decide where to place the code. We’ll use 
frame 80 since that is the frame we need to stop the playhead upon… but 
which layer? It is best practice in Flash Professional to create a layer called 
“Actions” where all of your frame scripts will be placed. Not only does this 
make it easy to find any of your code, but it also keeps the code separate 
from your visual assets which exist in other layers. So create a new layer and 
name it “Actions”. Now, insert a blank keyframe on frame 65 by choosing 
Insert > Timeline > Blank Keyframe from the application menu. 

 

2. Open the Action Panel from the application menu: Window > Actions. Now 
click on the “<>” icon to open the Code Snippets Panel. The Code Snippets 
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panel is a great way for those who are new to working with code to learn how 
to do some fundamental things within Flash Professional projects. The 
snippets included are divided into 3 main categories: ActionScript, HTML5 
Canvas, and WebGL. These correspond to whichever target platform you are 
working with. 

3. Choose ActionScript > Timeline Navigation > Stop at this Frame by double-
clicking upon it. The code, along with comments, is inserted within our 
Actions Panel. This will stop the playhead upon this frame. 

 

4. Our animation is now complete! Go ahead and choose File > Publish from the 
application menu to render the final output. 

Project 4: Conversion and Export 
Okay! We can publish for playback in Adobe Flash Player, but what about platforms 
that do not have Flash Player available? Time to publish this content in a variety of 
different formats – including native HTML5.  
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Target Any Platform You Desire 

Targeting Flash Player 

Flash Professional has deep roots in ActionScript and the 
Adobe Flash Runtimes: Flash Player and AIR. This should 
come as no surprise… for the majority of its lifetime – this 
was really the only supported platform! As a result, 
choosing any of the AS3-based document types allows for 
the fullest set of creative tooling and the use of a deeply 
mature programming language – ActionScript 3.0.  

We’ve created this project using an ActionScript 3.0 document type targeting Flash 
Player. And that is okay! Here are some statistics around Flash Player that may 
surprise you: 

• The standalone Flash Player runtime is updated 1.2 billion times per month* 
from Adobe. 
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• Integrated Flash Player is built into Google Chrome, Internet Explorer 11, and 
Microsoft Edge. 

• Every ChromeBook includes Flash Player. Huge for educational content. 

• 99% of Facebook gaming content 

• Add this all up – Flash Player is (still) everywhere! 

Exporting HD Video 

If we render our project to a web-friendly video format like 
MP4 – we don’t have to worry about the limitations of certain 
platforms. Just make an awesome little video! One of the 
major uses of Flash Professional is to animate and produce 
content for television and video… so we are good! The fact 
that an ActionScript 3.0 based document type is generally the 
best choice for video simply due to the amount of extra tools and filters that are 
available should not be overlooked. 

Choose File > Export > Export Video and then make some decisions around where to 
export the video and at what resolution. Flash Professional does a frame by frame 
rendering of the content… so what ends up in the video is precisely what was 
authored. It even takes into account dynamic animation through the use of 
ActionScript! 
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Once the video is rendered, we can fire up Adobe Media Encoder to render it to any 
format desired. You can also just import the video to an Adobe Premiere Pro or After 
Effects project. 

Conversion to HTML5 Canvas 

Content created in Flash Professional can now to be 
published directly to a number of modern HTML5 formats. 
The primary document type which allows this publish 
target is HTML5 Canvas. When creating content using this 
publish target, Flash Professional will leverage the 
CreateJS JavaScript libraries to output an entire 
animation or interactive project for the HTML5 canvas 
element. You can even write JavaScript in the Actions Panel! 

• About 30%-35% of Flash Professional users are targeting HTML5 Canvas 
document type.   

• In addition, the CreateJS CDN hits grew from 1.4 billion to 7.8 billion per 
month.  
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• That’s a lot of usage! 

To convert our ActionScript 3.0 document to HTML5 Canvas, choose Commands > 
Convert to Other Document Formats from the application menu. In the dialog that 
appears, choose HTML5 Canvas as your new document type and hit OK. 

 

Once created, have a look at any warnings that appear in the Output Panel. Any 
ActionScript will be commented out – and will need to be replaced with JavaScript, 
as Flash Professional does not convert any code in the process. 

Conversion to WebGL 

The secondary native HTML5 document type 
involves the use of WebGL (Web Graphics 
Library) technology. Interestingly enough, 
WebGL also makes use of the HTML5 canvas 
element… but in a different way. WebGL 
content is actually GPU-accelerated, meaning that it makes direct use of the 
hardware GPU (Graphical Processing Unit) instead of sharing rendering tasks with 
everything else running on the CPU (Central Processing Unit). This makes for a much 
more effective and powerful rendering target. 
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To convert our ActionScript 3.0 document to WebGL, we will use the same exact 
procedure use to convert to HTML5 Canvas. Choose Commands > Convert to Other 
Document Formats from the application menu. In the dialog that appears, choose 
WebGL (Preview) as your new document type and hit OK. 

 

Once created, have a look at any warnings that appear in the Output Panel. Any 
ActionScript will be commented out – and will need to be replaced with JavaScript. 
The Code Snippets Panel can be a great help here! 

Publishing for iOS and Android with AIR 

Additionally, we can publish directly to iOS and Android by 
leveraging Adobe AIR! AIR is hugely popular for building real 
apps across both desktop and mobile targeting Windows, 
OS X, iOS, and Android.  

• AIR Application Installs:  
4 BILLION (4,053,801,461 to be exact) 

• Mobile AIR applications:  
200k ( 173,258 Android & 42,924 iOS) 
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• #2 app development platform behind native on Android! 

While targeting Flash Player, Video, Canvas, or WebGL… we could just convert the 
document and just tweak things here or there… creating a native mobile app is a bit 
of a different story. We’ll probably want to rearrange the various elements on the 
Stage to accommodate the device resolution, as mobile apps are generally full 
screen experiences. Additionally, we’d most likely want to create a true app 
experience around such content, not have a simple animation be the entire app.  

Regardless – Adobe AIR is a great target for desktop and mobile app development 
that you can consider when working in Flash Professional CC! 

Using Custom Publish Targets 

As we have seen, Flash Professional supports 
creating rich assets and animations using 
native document types such as ActionScript 
3.0, HTML5 Canvas, and WebGL. The Custom 
Platform Support feature helps to extend the 
power of Flash Professional CC to support 
platforms that are not native to Flash 
Professional.   

Using the Custom Platforms SDK, a developer 
can integrate his or her own platform as a real FLA based target. By installing a 
platform support plugin for a new document type, Flash Professional users can 
create their assets using the rich feature set of Flash Professional and publish it in 
the output format of the custom platform!  
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Existing custom platform examples include: 

• Snap.svg Animator 

• GAF Publisher 

• OpenFL 

• Away3D 

Additional Resources 
To keep up on all things Flash Professional, here are a few resources: 

• Adobe Flash Professional Team Blog 
http://blogs.adobe.com/flashpro/  

• Adobe AIR and Adobe Flash Player Team Blog 
http://blogs.adobe.com/flashplayer/  

• Adobe Flash Professional CC Learn and Support 
https://helpx.adobe.com/flash.html  
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To contact Joseph Labrecque, note these links: 

• Website 
http://josephlabrecque.com/  

• Twitter Profile 
https://twitter.com/JosephLabrecque  

• Blog - In Flagrante Delicto! 
http://inflagrantedelicto.memoryspiral.com/  

• Lynda.com Author Page 
http://www.lynda.com/JosephLabrecque  

• Amazon.com Author Profile 
http://amazon.com/author/josephlabrecque  

 

 

 

THANK YOU & EXPLORE FLASH PROFESSIONAL! 
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